Minecraft Upgrade 1.12.2 & OptiFine

Hello everyone,

We are pleased to announce that all our servers have been upgraded to 1.12.2 as of 9/27/2017. This means that you also need to use the latest version (1.12.2) for your Minecraft Client to connect to our servers. Don't worry if you forget, as you'll get a message in your game showing what version is running on our server when you attempt to connect.

Also, we highly recommend installing OptiFine 1.12.2 and use this when playing on any 1.12.2 server, not just the TmTmc Servers. Why? This is a texture pack and utility which optimizes your game play and server interaction. Basically, it minimizes the "Lag" you may experience when playing in the game. OptiFine provides many, many additional Minecraft Options to customize your playing experience far more than the default.

To get your "free" copy of OptiFine, you can download it from here.

Featured Posts
Recent Posts
Archive
Search By Tags
No tags yet.
Follow Us
  • Facebook Basic Square
  • Twitter Basic Square
  • Google+ Basic Square
  • Facebook Black Round
  • Twitter Black Round
  • Instagram Black Round

© 2016-2020. Proudly created with Wix.com